FHB and Interrupts

Post Reply
motarius
Posts: 5
Joined: Tue Feb 14, 2012 3:41 pm

FHB and Interrupts

Post by motarius » Wed Jun 06, 2012 10:07 am

I've been working on a project that requires 2 flow sensors running on the standard interrupt pins (2,3). With only one flow sensor attached it works perfectly. However, when I attach the second sensor it causes only one of them to work, in that interrupts won't occur for the second sensor despite the same settings with a different pin. According to the Schematic for the FHB there's nothing on pins 2 and 3....but reading through some of the MAX code I did see there's a few interrupts, but I'm not sure what exactly they refer to. I guess the simple question is, how many interrupts will function correctly on the FHB?

paul
Site Admin
Posts: 735
Joined: Mon May 12, 2008 4:19 pm

Re: FHB and Interrupts

Post by paul » Wed Jun 06, 2012 10:35 am

motarius,

There are no connections to pins two and three in the schematic, so I think you are probably dealing with a software issue. That said it's also possible that the Max code is messing with the pins unnecessarily - due some legacy code that we didn't really rethink or repurpose. Sorry I can't provide much more than that as a clue. I haven't really made a project with the board that is interrupt driven. Mostly just reading analog sensors.

As a quick workaround and test - in addition to just commenting out pin interrupts in the code, you could use a pin change interrupt on another pin - you can find the code in the Arduino playground. Good luck with it and any report you care to make on your progress would be appreciated here.

Paul

Post Reply