Ethernet shield connection

Making your program work.
Post Reply
Ken
Posts: 4
Joined: Wed Feb 08, 2012 9:51 pm

Ethernet shield connection

Post by Ken »

Cannot send data to Ethernet shield

Microsoft Telnet Client command

Open hostname [port]

Does the Ethernet Shield have a hostname? I get error "not connected" if I just type in text.

Thanks for your help,

Ken
Ken
Posts: 4
Joined: Wed Feb 08, 2012 9:51 pm

Re: Ethernet shield connection

Post by Ken »

I can see the receive light flash on the Ethernet shield but no TX light. I get the message "Connecting to xxx... Could not open connection to the host. On port (23): Connect failed"

Ken
paul
Site Admin
Posts: 775
Joined: Mon May 12, 2008 4:19 pm

Re: Ethernet shield connection

Post by paul »

Ken,

Are you using the Arduino Ethernet shield? The red one? Arduino Ethernet library?
Just trying to get the facts straight.

Paul
Ken
Posts: 4
Joined: Wed Feb 08, 2012 9:51 pm

Re: Ethernet shield connection

Post by Ken »

My windows version is Vista, my Ethernet shield is new (and green) and the sketch is Arduino ChatServer and includes
#include <SPI> and #include <Ethernet.h>.

Hope this helps,

Ken
paul
Site Admin
Posts: 775
Joined: Mon May 12, 2008 4:19 pm

Re: Ethernet shield connection

Post by paul »

So it's the Arduino / Smart projects board? Can you tell me who made the board - because I thought the arduino board was red? I actually don't have a lot of experience with the Arduino Ethernet shield, so you'll probably get a better response on the Arduino forum.

Sorry to not have a better answer.

Paul
Ken
Posts: 4
Joined: Wed Feb 08, 2012 9:51 pm

Re: Ethernet shield connection

Post by Ken »

Hi Paul,

Thanks for your response. I'm a little above my head with this Arduino Shield but will continue to work with it.

You can find a discription on the second page of your Arduino products.

thanks again

Ken Shuck
Post Reply