Anyone got the MIDI input working on the Fluxamasynthshiel V.3?

Interfacing hardware, sensors, output drivers, chips.
Post Reply
Codeman
Posts: 1
Joined: Mon Apr 16, 2018 8:01 am

Anyone got the MIDI input working on the Fluxamasynthshiel V.3?

Post by Codeman » Sun Apr 29, 2018 11:19 am

Hi all,

I tried several hours to get the MIDI input running on my Fluxamasynth shield V.3 without success. I read the circuit diagrams and found out that it should be connected to pin 3 on my Arduino. But when connecting my Rolanf A800PRO and playing something absolute nothing happens with test scripts:
- Tested with Arduino UNO and MEGA
- Tested Hardware and SoftwareSerial

For hardware serial I used a jumper from pin 3 to pin 0 (UNO) or pin 19 (Serial1-RX on a MEGA)... nothing.

Has anyone an idea or perhaps my MIDI input is defect?

Regards, Holger

dfdtitmouse
Posts: 3
Joined: Mon Nov 18, 2019 10:00 am

Re: Anyone got the MIDI input working on the Fluxamasynthshiel V.3?

Post by dfdtitmouse » Mon Nov 18, 2019 10:07 am

I just got the board a few days ago. Same problem you had was that "thru MIDI" jumper pad had been set so had to use Pin 3 on the Fluxa board.

I've tested the MIDI (5 pin DIN) port with a keyboard controller (Alesis QX61). Works as intended (by default, the controller is set as a "grand piano") - got the sounds out. Next I'll try the MIDI Computer Output on the controller board so that the Fluxa board can be controlled via software DAW (Reaper - pretty good program, a lot more intuitive than the other higher priced stuff).

paul
Site Admin
Posts: 752
Joined: Mon May 12, 2008 4:19 pm

Re: Anyone got the MIDI input working on the Fluxamasynthshiel V.3?

Post by paul » Sun Dec 15, 2019 3:02 pm

Codeman,

Apologies for my slow response to the forum.
Was your board ordered with the MIDI options? When set to the midi jack we set the jumpers to the middle and right jumper (with the MIDI jack on the right).

I'll update this with the picture of the jumpers when set to midi jack input.

dfdtitmouse
Posts: 3
Joined: Mon Nov 18, 2019 10:00 am

Re: Anyone got the MIDI input working on the Fluxamasynthshiel V.3?

Post by dfdtitmouse » Mon Dec 16, 2019 1:16 pm

I've tried the MIDI connection using a USB/MIDI converter when operating the DAW (Reaper - still learning). Works fine - Rick James "Super Freak" sounds pretty good.

If you want to use as only as a MIDI based synthesizer, I would highly suggest using a USB/MIDI converter cable (relatively cheap - a good peripheral. Also, you need to power the board appropriately, unit has 3v3 regulator for the chip) when connecting with your computer - if you have a keyboard controller (or other device) with MIDI OUT, just connect directly to the built in MIDI port. The SAM2695 follows MIDI so there is no issues.

However, if you want to have this unit as a stand alone "music box", then follow ("decipher") the coding.

Post Reply