Problem with RBBB

Questions about the Really Bare Bones Board
Post Reply
tcoop25
Posts: 4
Joined: Fri May 16, 2008 6:21 am

Problem with RBBB

Post by tcoop25 » Fri May 16, 2008 6:24 am

I just bought a RBBB and the USB to serial cable. I assembled the board without the voltage regulator/power plug. I connect the serial cable, and the LED stays lit. I am getting 5v from the serial cable, but only 3 volts from all of the 5v power spots on the board. Any ideas? I am unable to upload any sketches either.

-TC

paul
Site Admin
Posts: 735
Joined: Mon May 12, 2008 4:19 pm

Re: Problem with RBBB

Post by paul » Fri May 16, 2008 10:04 pm

TC

The 3V reading is a bit of conundrum. It may just indicate that the current draw is much larger than it should be. Or you may have a flaky solder joint on a power line. Here are some things to try.

Chip in correctly? Cable connected with black wire to ground? 10K resistor to switch.
Diode in with stripe facing right pad (w switch on left).
Check your solder joins, reheat ones that look questionable and scrub with isopropyl alcohol and a toothbrush.

If you can, write back when you find the problem, I'd like to know and it may help others.

Paul

tcoop25
Posts: 4
Joined: Fri May 16, 2008 6:21 am

Re: Problem with RBBB

Post by tcoop25 » Sat May 17, 2008 11:15 pm

I am completely stumped. I checked all the solder joints, and they all look good and clean. I double checked the chip direction, and it is correct, and made sure now pins in the socket got pushed in. I put in the chip from my Arduino Dec. and same thing happened with that. Check the resistors and diode, and everything is ok. I put 5v to the power on the opposite side of the USB connection, and the LED lights up and stays lit like it did with the USB connected. The 5V locations on the board do read 5v when I connect this way, unlike when the USB is connected where they all read 3V.

Don't know where to go from here...

paul
Site Admin
Posts: 735
Joined: Mon May 12, 2008 4:19 pm

Re: Problem with RBBB

Post by paul » Mon May 19, 2008 10:24 pm

FTDI does make a 3.3V cable. Did you put a meter on the cable and see if 5V are coming out of the cable?

This sounds like it could be a possibility. Did you buy the cable from me? It's possible they had another cable mixed in with a batch, I buy them in fairly large lots so it could well have escaped my notice.

Paul

tcoop25
Posts: 4
Joined: Fri May 16, 2008 6:21 am

Re: Problem with RBBB

Post by tcoop25 » Tue May 20, 2008 9:33 pm

Argh. The FTDI cable (purchased from you) is 5V. I have no idea what is going on. I have triple checked everything, made sure everything is facing the right way, re-heated all of the solder joints...

...I'm stuck.

paul
Site Admin
Posts: 735
Joined: Mon May 12, 2008 4:19 pm

Re: Problem with RBBB

Post by paul » Tue May 20, 2008 11:52 pm

OK if you're really stuck, send the thing back and I'll fix it or give you new one. It's worth it to me to see all the error modes in my products and either fix the hardware or the instructions.

Paul

paul
Site Admin
Posts: 735
Joined: Mon May 12, 2008 4:19 pm

Re: Problem with RBBB - postscript

Post by paul » Sun Jun 01, 2008 7:30 pm

This turned out to be a broken trace on the positive power line, at the USB jack. I don't know if the customer did any swapping of parts or other repair on the board, I did a continuity test of 50 boards for a quick check and found no problems. Will watch to see if this problem surfaces again, but I suspect not. This may be one that we never get to the bottom of - or, I may eventually decide I have rare qc issues with my boards and need to change suppliers. Watchful waiting prescribed.

The repair was a short piece of wire stubbed in to duplicate the trace. The repaired board and a new kit is on the way to the customer.

Paul

tcoop25
Posts: 4
Joined: Fri May 16, 2008 6:21 am

Re: Problem with RBBB

Post by tcoop25 » Fri Jun 13, 2008 7:22 am

Paul, thank you so much for the fix. It was probably something I had done that caused the break....and I can't believe I couldn't find it! Also, thank you for the extra kit. That was above and beyond what I was expecting! Can't wait to see what other products you come out with. I will post pictures of my project in the forums when I am done.

FYI, I found that if you break off the voltage regulator on the boards, the RBBB fits perfectly width wise in an Altoids tin. :)

-Tyler

Post Reply