Cannot upload to BBB

Problems uploading, serial connections, BUBs, P4, FTDI cables, etc
Post Reply
Posts: 1
Joined: Sun Jan 24, 2021 1:25 pm

Cannot upload to BBB

Post by DaveS3456 »

I have a BBB Rev E w 328 that I cannot upload successfully. The classic messsage “avrdude...stk500...not in sync....”.

This BBB is about 4-6 years old I think and still runs a sketch I uploaded years ago with a BUB. I could not find the BUB so ordered a USB FTDI from Amazon and could not get it to work. So I ordered a new BUB III. Before it arrived I found the BUB which is labeled just “USB BUB” so it is a classic BUB? But I cannot get it to work.

I’ve reloaded the VCP FTDI
I’ve rebooted.
If press the reset button on the BBB the LED blinks once.
5.00 V on the BBB and BUB.
Driver for the COM port says it is 9600 baud.
Old sketch sends data to serial monitor and that works to display the data. Shows it’s operating at 9600 baud.
When attempting to upload, message says “Overriding Baud Rate 57600”. (Is something not configured correctly?)
10K resistor on 328 reset.
Set RTS on Close doesn’t make a difference.
Laptop is running Windows 8.1. (Old PC) Is that an issue?
I backed up Arduino IDE version to 1.8.8 but didn’t seem to make a difference.
I using selection for Duemilanove with 328P.
What is correct selection for programmer? Doesn’t seem to matter but I’ve most used the AvrISP MkII.
The BUB III has arrived but I haven’t tried it yet. Could I have bricked my BUB Classic? Might I brick the BUB III?
I think I also have a couple of JeeNodes but I haven’t tried/risked them yet.
Can’t make it work by reset before uploading.
Nothing on pins 0 and 1. Rx and Tx voltages vary with data and uploading attempts. As I can understand I think the shunts are correct.

Is it any clue that the Serial Monitor works but the upload does not? Suggestions welcome and best wishes! DS
Site Admin
Posts: 775
Joined: Mon May 12, 2008 4:19 pm

Re: Cannot upload to BBB

Post by paul »

If the BBB is really old, it may have a Diecimila bootloader on it.
Try that in boards menu - also try Uno - one those should work.

Are you using Mac or Windows? There can be problems with FTDI drivers on a Mac.
You are better off deleting the FTDI drivers and using the Apple built in FTDI drivers - for about the last four or five years.

That's about what I can think about now. Let me know if you can't figure out how to delete the FTDI drivers and I can post some links - there are a lot on the internet.

There are two places on the Mac where you need to look and delete drivers.
Post Reply