RBBB newb

Questions about the Really Bare Bones Board
Post Reply
loveforvdubs
Posts: 4
Joined: Wed Jan 04, 2012 11:17 am

RBBB newb

Post by loveforvdubs » Wed Jan 04, 2012 11:33 am

Hello all,

I am a bit of a RBBB newb, I have done a bit more with the Arduino Uno, but this is my first RBBB. I did all of the soldering last night and I am fairly confident with how it came out. I plug it in and the pin 13 LED blinks. When I try to upload I get this error: avrdude: stk500_getsync(): not in sync: resp=0x00. It sounds like this is pretty infamous. I have been reading a lot about it and have tried just about every suggestion I can find but am still not having any luck. I am using an USB BUB to program and I am tempted to lean towards that as the issue because none of the lights on the BUB blink or light up while programming. I am unsure if that is the issue though. Any guidance or help would be greatly appreciated. Thanks.

loveforvdubs
Posts: 4
Joined: Wed Jan 04, 2012 11:17 am

Re: RBBB newb

Post by loveforvdubs » Wed Jan 04, 2012 12:18 pm

I got it figured out. I set the board to Duemilanove 328 (I was Uno and Mini 328 before) and that fixed it. I was able to upload new programs . So all is well in RBBB land! :D

Carloscoleman
Posts: 4
Joined: Mon Jan 28, 2013 1:46 pm

Re: RBBB newb

Post by Carloscoleman » Tue Jan 29, 2013 5:47 am

loveforvdubs wrote:Hello all,

I am a bit of a RBBB newb, I have done a bit more with the Arduino Uno, but this is my first RBBB. I did all of the soldering last night and I am fairly confident with how it came out. I plug it in and the pin 13 LED blinks. When I try to upload I get this error: avrdude: stk500_getsync(): not in sync: resp=0x00. It sounds like this is pretty infamous. I have been reading a lot about it and have tried just about every suggestion I can find but am still not having any luck. I am using an USB BUB to program and I am tempted to lean towards that as the issue because none of the lights on the BUB blink or light up while programming. I am unsure if that is the issue though. Any guidance or help would be greatly appreciated. Thanks.
Congrats you have sorted the issue. Please explain how you did it.

paul
Site Admin
Posts: 733
Joined: Mon May 12, 2008 4:19 pm

Re: RBBB newb

Post by paul » Tue Jan 29, 2013 9:02 am

Carloscoleman,

Are you having issues uploading?
Try try the UNO board setting - if no luck maybe you have an older board.
Try the Duemilanove setting.
Still no luck?
Put an LED from pin 13 to ground through a 220 - 1k resistor.
Push the reset button and see if the LED flashes - that's the bootloader flashing the LED.
Write back

Hope that helps,
Paul

Carloscoleman
Posts: 4
Joined: Mon Jan 28, 2013 1:46 pm

Re: RBBB newb

Post by Carloscoleman » Wed Jan 30, 2013 2:30 am

Carloscoleman wrote:
loveforvdubs wrote:Hello all,

I am a bit of a RBBB newb, I have done a bit more with the Arduino Uno, but this is my first RBBB. I did all of the soldering last night and I am fairly confident with how it came out. I plug it in and the pin 13 LED blinks. When I try to upload I get this error: avrdude: stk500_getsync(): not in sync: resp=0x00. It sounds like this is pretty infamous. I have been reading a lot about it and have tried just about every suggestion I can find but am still not having any luck. I am using an USB BUB to program and I am tempted to lean towards that as the issue because none of the led lights on the BUB blink or light up while programming. I am unsure if that is the issue though. Any guidance or help would be greatly appreciated. Thanks.
Congrats you have sorted the issue. Please explain how you did it.

Post Reply