External Power Problem (USB BUB is OK)

Questions about the Really Bare Bones Board
Post Reply
Will
Posts: 1
Joined: Sat Jan 09, 2010 7:46 pm

External Power Problem (USB BUB is OK)

Post by Will » Sat Jan 09, 2010 8:17 pm

I recently assembled an RBBB and was load and run some test programs using the USB BUB Board.

When I connect an AC adapter to the power jack the power indicator doesn't come on (the TO-92 really hot so I guess that was at least part of the problem).

The AC adapter is 5v anyway so I moved it in front of the regulator but it still doesn't light up the power indicator when I plug it in.

Any idea what could be wrong?

Thanks.

floresta
Posts: 93
Joined: Mon Jul 28, 2008 6:52 pm
Location: Western New York, USA
Contact:

Re: External Power Problem (USB BUB is OK)

Post by floresta » Sun Jan 10, 2010 11:54 am

Will:
Since your RBBB works when powered from the USB BUB it narrows the problem down pretty much to the regulator or your external supply. The only other part to consider is the 47uF input capacitor but if that were shorted the regulator wouldn't get hot. Are you sure the regulator is mounted properly, with it's flat side facing out? Your AC adapter should be supplying a DC voltage of 5 volts or more with the + on the center pin.

Don

paul
Site Admin
Posts: 732
Joined: Mon May 12, 2008 4:19 pm

Re: External Power Problem (USB BUB is OK)

Post by paul » Thu Jan 14, 2010 8:25 pm

Sorry about the slow reply Will,

Looks like you have a short somewhere, which would explain - no pilot light + hot regulator. Also check to make sure the regulator is in correctly . Check direction of the protection diodes. Unless there's some really bad soldering I'd bet on a diode being in backwards.

Paul

Post Reply