BUB II connected to RBBB Pro - weird serial output

Problems uploading, serial connections, BUBs, P4, FTDI cables, etc
Post Reply
arieljake
Posts: 1
Joined: Sat Dec 15, 2012 9:59 pm

BUB II connected to RBBB Pro - weird serial output

Post by arieljake » Sat Dec 15, 2012 10:04 pm

As soon as I open the serial monitor, the output below keeps spewing. Any ideas what is causing this?
I tried another BUB, same thing.

expected value of pin 14 = 111 actual value: 280

expected value of pin 15 = 222 actual value: 283

expected value of pin 16 = 333 actual value: 289

expected value of pin 17 = 450 actual value: 288

expected value of pin 18 = 566 actual value: 287

expected value of pin 19 = 680 actual value: 279

expected value of pin 20 = 790 actual value: 283

expected value of pin 21 = 909 actual value: 278
Pin 2 won't go HIGH
Pin 3 won't go HIGH
Pin 4 won't go HIGH
Pin 5 won't go HIGH
Pin 6 won't go HIGH
Pin 7 won't go HIGH
Pin 8 won't go HIGH
Pin 9 won't go HIGH
Pin 10 won't go HIGH

paul
Site Admin
Posts: 733
Joined: Mon May 12, 2008 4:19 pm

Re: BUB II connected to RBBB Pro - weird serial output

Post by paul » Tue Dec 18, 2012 11:10 am

arieljake,

This is just our test program for the RBBB Pro. It tests every pin.
I guess we should burn things back to blink when we're done, but it would add time and cost to production.

You might need to hit the reset button when uploading and may need to do this a few different times. Optiboot is kind of fussy about properly interrupting a serial stream to reset processor and upload, if the serial stream is fairly fast.

Let me know how you make out,

Paul

Post Reply