RBBB and USB BUB II - serial port

Problems uploading, serial connections, BUBs, P4, FTDI cables, etc
Post Reply
DaveW
Posts: 8
Joined: Wed May 09, 2012 11:52 am

RBBB and USB BUB II - serial port

Post by DaveW » Sat Jun 02, 2012 6:47 pm

I just put together the RBBB kit, connected the BUBII to it,downloaded ARDUINO 1.0.1 and tried to upload the blink sketch from my Macintosh to make sure everything was OK. In the Arduino IDE, I set the board to Arduino Uno and the programmer to AVRISP mkII. Are these the correct settings?

The problem I am having is in setting the serial port. With the USB-BUB II connected to the mac no virtual port comes up in the IDE when I select Tools:serial port:, and all I get is the standard mac ports that are already in use.

In comparison, when I connect an Arduino Uno to my mac, a port shows up in the scrolling list that I can select named /dev/tty.usbmodem 621.

Are some of my setting incorrect? Any ideas?

-DaveW

paul
Site Admin
Posts: 735
Joined: Mon May 12, 2008 4:19 pm

Re: RBBB and USB BUB II - serial port

Post by paul » Sat Jun 02, 2012 9:00 pm

The problem is the FTDI serial drivers - they used to be included with Arduino - maybe they still are but because the Arduino guys are using different USB solutions now, they don't make it that obvious where to get the FTDI drivers.

Download them from here:
http://www.ftdichip.com/Drivers/VCP.htm

Just pick out whatever seems appropriate for your operating system. You probably won't have to restart.


Paul

DaveW
Posts: 8
Joined: Wed May 09, 2012 11:52 am

Re: RBBB and USB BUB II - serial port

Post by DaveW » Sun Jun 03, 2012 12:55 pm

Thanks for the reply. I downloaded the FTDI driver and now have been able to select a virtual port(/dev/tty.usbserial-A4011723). The Blink sketch compiles fine but when I upload to the Arduino board I get an error message 'Problem uploading to board. See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions'. The error message seemed to come from this:
avrdude: stk55_recv(): programmer is not responding.

Could this be due to a shunt issue on the BUBII? I wasn't clear if the little red shunts should be used for the Arduino and so I have no shunts on the board.

-DaveW

paul
Site Admin
Posts: 735
Joined: Mon May 12, 2008 4:19 pm

Re: RBBB and USB BUB II - serial port

Post by paul » Sun Jun 03, 2012 2:10 pm

The BUB should run fine out of the box (well plastic bag) once you solder headers on it.

Did you buy the RBBB recently - Try both the UNO and Duemilanove settings in Arduino, in case the chip somehow has the older bootloader on it.
If you're new at soldering try reheating the connections to the programming header and the chip pins.
You can hook up an LED between ground and pin 13 in series with a 1K resistor - it should blink in some manner when you push the reset button or apply power. This will confirm the presence of a bootloader.

Maybe try a computer restart. Confirm that you have the correct resistor values for the reset pullup near the programming jack (10K).

That's about what I can think of right now. If you really get stuck send it back to the shop - marked repair and return and we'll fix it and send it back to you.

Paul

DaveW
Posts: 8
Joined: Wed May 09, 2012 11:52 am

Re: RBBB and USB BUB II - serial port

Post by DaveW » Mon Jun 04, 2012 10:05 pm

Paul,

Atmega chip in backwards. Beginners mistake. Now the RBBB and the BUB II are working as expected. Thanks for the help.

-Dave

Post Reply