Page 1 of 1

Sanguino in Arduino 1.0

Posted: Tue Jul 10, 2012 11:59 am
by mpboddie
Last night I was having issues with getting a Sanguino up and running last night, but I've got it working now. Here is a brief over view of what was going on. Please either use this info or give some constructive criticism if you see any problems or more info to add.

Gratuitous description of problems encountered
So I was originally running crunchbang (debian based OS) and arduino 0018 (the version in the repository). I went through the installation steps at I did not running the debian specific steps because I checked my versions and they were much greater than the ones listed in the how to. The sanguino options appeared in the arduino software and I picked the 644P option which I confirmed on the hardware. The issue came when I went to upload a sketch. I would try the blink sketch but I would always receive the message of
stk500_recv() programmer is not responding
From here I panicked that I did something foolish during hardware assembly and triple checked everything. Once I was fairly sure that was fine I tried the ubuntu specific steps from the previous sanguino link. That also did not work. I tried a ton of other steps like manually resetting before uploads and updating to 0023 and 1.0 from the arduino site, repeating steps for each of those versions with no luck. With arduino 1.0, no sketches would even compile.

So then because it was going to happen eventually for unrelated reasons, I reluctantly switched the computer I was on over to Ubuntu 12.04. I know don't think this helped or hurt, but I am adding it for completeness. I then installed arduino 1.0 from the repository and had the same issues as with crunchbang and 1.0. I also tried 0023 from the arduino site and sketches would compile but I would still get the not responding error from above. I tried a pretty much everything I did with crunchbang along with trying some different sources for the sanguino software, none of which worked until...

I tried using the software from and it worked like a charm. Just put the files in a folder just like you would with the sanguino software instructions. This allowed me to compile and upload to a sanguino with the arduino 1.0 software. I was kind of avoiding the 1.0 software for a while because it seems like there are some significant changes, but in the back of my head, once I maxed out the room of a BBB, I knew it would be best to make the 1.0 changes now rather than later.

I hope this helps, and please if you have anything to add or if you feel that I did something wrong, let me know.

Re: Sanguino in Arduino 1.0

Posted: Tue Jul 10, 2012 1:05 pm
by paul
I've never done the linux install of Sanguino on Arduino IDE. The Mac version on Arudino 1.0 didn't take me too long to figure out though.


Re: Sanguino in Arduino 1.0

Posted: Tue Jul 10, 2012 4:37 pm
by mpboddie
Hmmmmm, now I am interested as to why it didn't work with the software from sanguino. Paul, when you install in Mac OS X with the Arduino 1.0 sdk, do you use the 0023 zip (

Maybe it was just a problem with a package in crunchbang.

Re: Sanguino in Arduino 1.0

Posted: Thu Nov 15, 2012 10:22 pm
by paul
I would just go for the most recent file which seemed to be this one

You definitely need the Arduino 1.0 support.


Sanguino in Arduino 1 0

Posted: Thu Sep 28, 2017 7:14 pm
by Dudemhccv

and thank you

using the satelite with a arduino micro will be nice for small copters .